Problem with my 66s....

Discussion related to the Garmin GPSMAP 66 series GPSr
Post Reply
Posts: 2
Joined: Sun Jan 13, 2019 7:59 am

Problem with my 66s....

Post by mimichris » Sun Jan 13, 2019 8:04 am

This morning Sunday 12/01, I turn on my Gpsmap 66s and it does not start, it remains on the Garmin start page.

I remove the μSD and batteries I wait a little while then put the batteries, same problem.

I'm trying to reboot the 66s. I simultaneously pressed "page" and "enter" then "on", it asks to "delete user data", which I did but nothing happens at restart.
I start again but this time the request is in English, as it has deleted the user data but it does not restart better.

I also tried the method you sent to a colleague who had a blockage of his 66s:

In order to completely reset your GPS please:
1- Turn off the GPS
2- Position yourself in an open corner, outside.
3- Hold the following buttons: "QUIT" + "MENU" "OUT".
4- Press the "POWER" button while holding down the "QUIT" + "MENU" "OUT" buttons.
5- When the device turns on, after 5 seconds, release the "POWER" button, and then release the other buttons (the display must remain on Garmin).
6- The GPS restarts and asks for your country, enter the settings. Your device is reset.
Attention, this manipulation is a reset, so this may delete all your user data (routes, waypoints or registered addresses, settings etc ...), remember to make a backup on your computer as far as possible.

It's inoperative .....

On the other hand, the screen remains a little bright for two to four minutes after removing the batteries, I see Garmin on the screen, as if the screen had afterglow, it did not when it was working normally.

Can not connect it to a USB cable to the PC, unrecognized.

An idea ?

Site Admin
Posts: 376
Joined: Fri Jan 20, 2017 11:29 pm

Re: Problem with my 66s....

Post by gpsrchive » Sun Jan 13, 2019 3:13 pm

If the GPSMAP 66 has a uSD card installed, remove the uSD card and reboot the device. If this is not successful, try the Forced USB Mass Storage Mode procedure and remove all personal data from the device and reboot. If a corrupted file is the problem, this should restore proper operation to your GPSMAP 66.

The Forced USB Mass Storage Mode procedure can be found in Function > Operation > Recovery.

If you are not certain which files or folders on the GPSMAP 66 you can safely remove, try renaming these folders (your device may not have all of these):

Activities > Activities OLD
Adventures >Adventures OLD
Apps >Apps OLD
BirdsEye >BirsdEye OLD
CustomMaps > CustomMaps OLD
CustomSymbols > CustomSymbols OLD
Filters > Filters OLD

You can do one folder at a time and reboot, or several at a time, or even all at once. If this restores proper function, the fun begins by reconnecting and deleting the replacement folders and removing the 'OLD' added to the originals, one at a time, until you discover which directory prevents your GPSMAP 66 from starting. Then, you get to play the same game with all files in the offending directory until you find the corrupted file.

Please let us know if this works for you!

Posts: 2
Joined: Sun Jan 13, 2019 7:59 am

Re: Problem with my 66s....

Post by mimichris » Sat Jan 26, 2019 10:01 am


Of all the recovery methods, none worked, so I sent it back to Garmin who returned a new 66s ... Everything ends well, thank you for your answer.

Post Reply