Compass problem with new Montana 610

Discussion related to the Garmin Montana 6x0 GPSr
Post Reply
Warekiwi
Posts: 2
Joined: Sat Apr 08, 2017 11:20 am

Compass problem with new Montana 610

Post by Warekiwi » Sun Jun 25, 2017 10:01 pm

I recently updated my old Montana 600 to a 610 model-- mainly for the GLONAS ability which improves the lock-on time and overall accuracy. Sadly though I discovered what may be a "bug" or perhaps a component failure with the 610. It's fine whilst moving but gets lost very quickly when stopped- it seems that the compass function loses it's calibration quite quickly- not something I ever had to concern myself about with the old 600. If I go through the calibration procedure then things remain OK until shutdown but randomly fail again at next use (the compass points anywhere except in the right direction when stopped) I've got the latest firmware (Ver 2.80) and have tried re-installing this and also doing a full hard reset but to no avail! Has anyone else had this happen? (I'm starting to wish I had kept my old 600!)

Warekiwi
Posts: 2
Joined: Sat Apr 08, 2017 11:20 am

Re: Compass problem with new Montana 610

Post by Warekiwi » Sat Jul 01, 2017 12:12 pm

I sent the following email to Garmin UK support today-
"'I've recently upgraded my venerable Montana 600 to a 610 and am sadly disappointed.. On receipt I upgraded the firmware to Ver 2.8. I have purchased Garmin Navigator EU NT plus I have various open-source maps (previously used on my 600) The 610 compass is faulty- and can indicate directional errors of in excess of 100 degrees Calibration sometimes fixes this for short periods but at next start-up the errors reappear making the device almost useless. I never experienced these problems with my 600! I HAVE done the usual things such as full (Hard) reset and reinstalling software- all to no avail. I am a VERY experienced Montana user and am very computer literate. Please advise what to do next!"

Just a few minutes later I plugged in the 610 to discover that Garmin had just released S/W Ver 2.90-- I've installed that and will see if it makes any difference but I'm starting to suspect a hardware (not software ) problem. Tomorrow I'll be doing a 60+ mile ride so will see if the compass is any better!

Post Reply