Oregon 7x0 Firmware 3.50

Discussion related to the Garmin Oregon 7x0 GPSr
Post Reply
gpsrchive
Site Admin
Posts: 114
Joined: Fri Jan 20, 2017 11:29 pm

Oregon 7x0 Firmware 3.50

Post by gpsrchive » Tue Oct 24, 2017 1:29 am

Released October 23, 2017. Resolves bug 17 (introduced in Firmware 3.40) where the active track log would be deleted over a power cycle.

Available with Garmin Express or from the Firmware page here!

Please post any observations/new bugs/comments for firmware 3.50 in this thread!

Thank You!

User avatar
EddyG
Posts: 14
Joined: Sat Feb 18, 2017 8:07 am
Location: Rhenen

Re: Oregon 7x0 Firmware 3.50

Post by EddyG » Tue Oct 24, 2017 7:15 am

Still a few BUG are still not solved.
There is a bug in the classic menu, where a key-sequence leads to an abnormal mainscreen. (see below)
There is a bug in the Geocache map screen, where the screen update is very slow compared to other profiles.
The "Current.gpx" bug still present, not completely solved.
A little bug in Autopause settings is still present.

1. Classic menu
2. Enter Map
3. Click on the hamburger menu, right bottom.
4. Select Setup map
5. Now directly return with return arrow on the left bottom.
6. Exit the map with the ‘X’ on the left bottom
7. The Time which is normally there is GONE.
Eddy

Forerunner 305, Edge 305, Colorado 300, Oregon 450, GPSmap 62s, Montana 650, Oregon 600, Oregon 750t

gpsrchive
Site Admin
Posts: 114
Joined: Fri Jan 20, 2017 11:29 pm

Re: Oregon 7x0 Firmware 3.50

Post by gpsrchive » Wed Oct 25, 2017 2:31 pm

EddyG wrote:
Tue Oct 24, 2017 7:15 am
Still a few BUG are still not solved.
There is a bug in the classic menu, where a key-sequence leads to an abnormal mainscreen. (see below)
There is a bug in the Geocache map screen, where the screen update is very slow compared to other profiles.
The "Current.gpx" bug still present, not completely solved.
A little bug in Autopause settings is still present.

1. Classic menu
2. Enter Map
3. Click on the hamburger menu, right bottom.
4. Select Setup map
5. Now directly return with return arrow on the left bottom.
6. Exit the map with the ‘X’ on the left bottom
7. The Time which is normally there is GONE.
Bug 18 in Common Issues addresses the Classic Menu Dashboard issue, I believe.
Please tell me more about issues you are still having with the 'Current.gpx' file, and the Autopause function.

User avatar
EddyG
Posts: 14
Joined: Sat Feb 18, 2017 8:07 am
Location: Rhenen

Re: Oregon 7x0 Firmware 3.50

Post by EddyG » Sat Oct 28, 2017 2:54 pm

If you connect the GPS to the computer before the GPS has a sat lock, then the current.gpx is empty.
That empty gpx file gives the error.
When ever there is min. 1 valid record in the gpx file then there is no error.

B.t.w. the problem as in bug 18 is also present when you touch the screen, remove the pin and go back to the mainscreen.

The autopause bug is a little bug, just a small programming error.
When you have a virgin GPS the autopause is on with a min value (I beleave 2,41 km/h).
When ever you touch the setting the default value is not accepted any more.
Is states Pause speed to low.
You have to fill in 2,42 km/h, just a little bit more.
I wanted to set it to 2,00 km/h, and that cannot be done. WHY??? :o :o :o

Still a lot to do for the dev. team of Garmin.
Last edited by gpsrchive on Sat Oct 28, 2017 8:07 pm, edited 1 time in total.
Reason: typo
Eddy

Forerunner 305, Edge 305, Colorado 300, Oregon 450, GPSmap 62s, Montana 650, Oregon 600, Oregon 750t

gpsrchive
Site Admin
Posts: 114
Joined: Fri Jan 20, 2017 11:29 pm

Re: Oregon 7x0 Firmware 3.50

Post by gpsrchive » Sat Oct 28, 2017 9:00 pm

EddyG wrote:
Sat Oct 28, 2017 2:54 pm
If you connect the GPS to the computer before the GPS has a sat lock, then the current.gpx is empty.
That empty gpx file gives the error.
What error exactly are you seeing?
EddyG wrote:
Sat Oct 28, 2017 2:54 pm
When ever there is min. 1 valid record in the gpx file then there is no error.

B.t.w. the problem as in bug 18 is also present when you touch the screen, remove the pin and go back to the mainscreen.
I suspect this will be resolved very soon.
EddyG wrote:
Sat Oct 28, 2017 2:54 pm
The autopause bug is a little bug, just a small programming error.
When you have a virgin GPS the autopause is on with a min value (I beleave 2,41 km/h).
When ever you touch the setting the default value is not accepted any more.
Is states Pause speed to low.
You have to fill in 2,42 km/h, just a little bit more.
I wanted to set it to 2,00 km/h, and that cannot be done. WHY???
Same here, but I am using MPH, which the minimum accepted value is 1.5mph.

Why? Think about it.

Autopause is intended to prevent excessive logging of track log points while stationary. Even under the best of circumstances, the GPSr accuracy is about 9 feet (approximately 2.7 meters). Anything less than 2,4 km/h (or 1.5mph) would likely result in autopause never being enabled due to the physical accuracy limits of the device! Thus, the Garmin software engineers have put this minimum value requirement in place to protect you from yourself!
EddyG wrote:
Sat Oct 28, 2017 2:54 pm
Still a lot to do for the dev. team of Garmin.
They are working hard at it right now!

User avatar
EddyG
Posts: 14
Joined: Sat Feb 18, 2017 8:07 am
Location: Rhenen

Re: Oregon 7x0 Firmware 3.50

Post by EddyG » Sun Oct 29, 2017 10:29 am

gpsrchive wrote:
Sat Oct 28, 2017 9:00 pm
What error exactly are you seeing?
The error is in Garmin Express about an invalid current.gpx.
Garmin should sort this out between the GPS dev. and the GE team.
gpsrchive wrote:
Sat Oct 28, 2017 9:00 pm
I suspect this will be resolved very soon.
I hope so too, because this has been too long for such a simple bug.
gpsrchive wrote:
Sat Oct 28, 2017 9:00 pm
Why? Think about it.
I did. I do not want people think for me, I can do that my self.
First of all those guys from Garmin still do NOT think metric.
2.40 km/h is a strange number to us who do think and act metric.
If the number would be 1.24 mph (2.00 km/h) you would think so too.
So why is the majority of the world denied to set it to 2.00 km/h.
The developers "allowed" us to set the units to metric but not in this setting.

For disbeleavers: https://en.wikipedia.org/wiki/Metric_system
Eddy

Forerunner 305, Edge 305, Colorado 300, Oregon 450, GPSmap 62s, Montana 650, Oregon 600, Oregon 750t

Davidppo
Posts: 1
Joined: Tue Oct 16, 2018 1:41 pm

Re: Oregon 7x0 Firmware 3.50

Post by Davidppo » Tue Oct 16, 2018 1:51 pm

EddyG wrote:
Sun Oct 29, 2017 10:29 am
gpsrchive wrote:
Sat Oct 28, 2017 9:00 pm
What error exactly are you seeing?
The error is in Garmin Express about an invalid current.gpx.
Garmin should sort this out between the GPS dev. and the GE team.
gpsrchive wrote:
Sat Oct 28, 2017 9:00 pm
I suspect this will be resolved very soon.
I hope so too, because this has been too long for such a simple bug.
gpsrchive wrote:
Sat Oct 28, 2017 9:00 pm
Why? Think about it.
I did. I do not want people think for me, I can do that my self.
First of all those guys from Garmin still do NOT think metric.
2.40 km/h is a strange number to us who do think and act metric.
If the number would be 1.24 mph (2.00 km/h) you would think so too.
So why is the majority of the world denied to set it to 2.00 km/h.
The developers "allowed" us to set the units to metric but not in this setting.

For disbeleavers: https://en.wikipedia.org/wiki/Metric_system
Thanks for the link.

Post Reply