Where To? > Extras POI bug

Discussion related to the Garmin Oregon 7x0 GPSr
Post Reply
Plato
Posts: 25
Joined: Sat Jun 17, 2017 3:58 pm

Where To? > Extras POI bug

Post by Plato » Fri Jan 12, 2018 8:24 am

On forums.geocaching.com member wwjd7 attended us to a little problem with the listing of extra poi (Where To? > Estras).
Unrelated to routing, I've noticed my first two POIs listed (under the Extras menu) always show the same distance and direction. At first I thought my CSV import contained duplicate coordinates, but CSV file contents are correct. It appears to be a bug in the way POIs are displayed in the list. The good news is that navigation to either POI still result in correct route calculations, so it's not a showstopper, it's just a small annoyance.
I can confirm this bug on my Oregon 700 v3.90. I have many custom POI in different categories and in every category the first two entries show the same distance and direction.

gpsrchive
Site Admin
Posts: 96
Joined: Fri Jan 20, 2017 11:29 pm

Re: Where To? > Extras POI bug

Post by gpsrchive » Fri Jan 12, 2018 1:08 pm

Thank you for reporting this bug. Posted to the Common Issues page as BUG 24.The Garmin software engineers never cease to disappoint!

gpsrchive
Site Admin
Posts: 96
Joined: Fri Jan 20, 2017 11:29 pm

Re: Where To? > Extras POI bug

Post by gpsrchive » Fri Jan 12, 2018 1:57 pm

I also notice some additional POI entries in that same list show inaccurate/incorrect distance and bearing information.

gpsrchive
Site Admin
Posts: 96
Joined: Fri Jan 20, 2017 11:29 pm

Re: Where To? > Extras POI bug

Post by gpsrchive » Fri Jan 12, 2018 2:44 pm

I have determined the entire distance/bearing database has been duplicated and offset by one position in the list, causing each POI to display the actual distance and bearing for the POI directly preceding in the list.

Plato
Posts: 25
Joined: Sat Jun 17, 2017 3:58 pm

Re: Where To? > Extras POI bug

Post by Plato » Fri Jan 12, 2018 5:28 pm

Thanks for sorting out exactly what's the problem.
It's incredible how many new bugs creap in with almost every firmware update!

gpsrchive
Site Admin
Posts: 96
Joined: Fri Jan 20, 2017 11:29 pm

Re: Where To? > Extras POI bug

Post by gpsrchive » Fri Jan 12, 2018 7:05 pm

Plato wrote:
Fri Jan 12, 2018 5:28 pm
Thanks for sorting out exactly what's the problem.
It's incredible how many new bugs creap in with almost every firmware update!
Kinda like Easter Eggs.... I don't think we find them all....

Plato
Posts: 25
Joined: Sat Jun 17, 2017 3:58 pm

Re: Where To? > Extras POI bug

Post by Plato » Fri Feb 23, 2018 6:09 pm

This bug is solved with the new firmware v4.00 that was released today. I checked it and it looks OK now.
- Fixed issue with the wrong distance and bearing displayed for GPI lists.
Last edited by Plato on Sat Feb 24, 2018 1:18 pm, edited 1 time in total.

gpsrchive
Site Admin
Posts: 96
Joined: Fri Jan 20, 2017 11:29 pm

Re: Where To? > Extras POI bug

Post by gpsrchive » Sat Feb 24, 2018 12:22 pm

Plato wrote:
Fri Feb 23, 2018 6:09 pm
This bug is solved with the new firmware v4.00 that was released today. I checked it and iy looks OK now.
- Fixed issue with the wrong distance and bearing displayed for GPI lists.
Thank you for confirming this fix!

Post Reply