Search found 20 matches

by Mikkyp20
Sat Jun 08, 2019 7:54 pm
Forum: Garmin Oregon 7x0
Topic: Lost Satellite Reception
Replies: 1
Views: 190

Re: Lost Satellite Reception

I'm surprised no one has commented on this issue.

Last month I did a full factory reset on the unit and everything has worked fine since. Let's hope this will permanently fix this. :D
by Mikkyp20
Mon Mar 25, 2019 11:29 pm
Forum: Garmin GPSMAP 66 series
Topic: cannot edit routes downloaded from Basecamp
Replies: 5
Views: 298

Re: cannot edit routes downloaded from Basecamp

Same for me, (I use Mapsource), on both GPSMAP66s and 0750t. I can only edit routes created on the GPSr.
by Mikkyp20
Sat Mar 23, 2019 4:22 am
Forum: Garmin Oregon 7x0
Topic: Lost Satellite Reception
Replies: 1
Views: 190

Lost Satellite Reception

I have an O750t with FW 4.40. On 3 occasions I have lost the satellite signal in a clear open sky while out cycling. Each time was in different parts of the town and after using the GPSr for approx 4 hours. Each time I was using white or black Eneloop batteries and there was one or more bars indicat...
by Mikkyp20
Mon Mar 11, 2019 8:24 pm
Forum: Garmin GPSMAP 66 series
Topic: Register Device for Geocaching
Replies: 5
Views: 316

Register Device for Geocaching

When I first got my GPSMAP 66s and set it up for geocaching the unit required that I REGISTER DEVICE. This would enable live geocaching. I came from a GPSMAP 64s which did not have live Geocaching and load my geocaches from GSAK in the GGZ format. I found that there was no way to bypass this screen....
by Mikkyp20
Wed Mar 06, 2019 3:25 am
Forum: Garmin GPSMAP 66 series
Topic: Another Feature Request?
Replies: 10
Views: 679

Re: Another Feature Request?

I support this request.

I would also like to add this feature request to the Oregon 7xx GPS.
by Mikkyp20
Thu Feb 28, 2019 1:19 am
Forum: Garmin GPSMAP 66 series
Topic: Firmware 2.50 Issues
Replies: 3
Views: 312

Firmware 2.50 Issues

I have experienced a number of issues after updating the Firmware to 2.50. 1 The unit sometimes turns off when changing pages. This has happened a number of times. 2 After selecting a geocache to go to, then going back to the geocaching page I am presented with a list of geocaches, and have to again...
by Mikkyp20
Thu Feb 28, 2019 1:00 am
Forum: Garmin Oregon 7x0
Topic: Geocaching Register Device
Replies: 1
Views: 223

Geocaching Register Device

When I first setup the O750 for geocaching the unit required that I REGISTER DEVICE. This would enable live geocaching. Being a dinosaur used to loading my geocaches from GSAK I found that there was no way to bypass this screen. Then I loaded the O750 with some caches using GSAK and the screen went ...
by Mikkyp20
Thu Feb 21, 2019 12:57 am
Forum: Garmin Oregon 7x0
Topic: Classic mode, main menu, day mode background.
Replies: 2
Views: 276

Classic mode, main menu, day mode background.

I have recently replaced my Oregon 650 with the 750t now running firmware version 4.40. On the 650 main menu, there is an option to choose the background to identify which profile (activity) is being used. On the 750, in setting up the activity mode there are a selection of icons and colors to choos...
by Mikkyp20
Fri Dec 21, 2018 2:37 am
Forum: Garmin GPSMAP 66 series
Topic: Issues with GPSMAP 66s
Replies: 14
Views: 1378

Re: Issues with GPSMAP 66s

In the last few days I have been having problems calibrating the compass. The first 2 stages work fine then the 3rd stage fails, repeatedly. Sometimes calibration is sucessful if I move location about 20m, but not all of the time. This was never an issue with the 64s.

Anyone else have this issue?
by Mikkyp20
Fri Dec 21, 2018 2:31 am
Forum: Garmin GPSMAP 66 series
Topic: Issues with GPSMAP 66s
Replies: 14
Views: 1378

Re: Issues with GPSMAP 66s

In answer to Wwerner

Did you change the profiles menu?
The profile I am using is for geocaching / not changed. Changing profiles creates more problems in my experience with the gpsmap 64s, so I don't change it very often now.

Are you using Expedition mode?
Expedition mode has been disabled.